Back under the Camaro again :-(

Open SCC Discussions
Post Reply
User avatar
Dion.Rentos
Posts: 2096
Joined: Sun Aug 26, 2012 1:41 pm
Location: Palm Bay Florida
Contact:

Back under the Camaro again :-(

Post by Dion.Rentos » Thu Sep 13, 2012 3:45 pm

Back under the Camaro again

Pulled up to close to the parking stops and one just hit my light bar under the front of the car. :obscene-hanged:

Broke the 2 mounts. I got one left and might have find something else to hold it up now

User avatar
AntiPriuSS
Posts: 198
Joined: Mon Aug 27, 2012 4:27 pm
Location: Satellite Beach

Re: Back under the Camaro again :-(

Post by AntiPriuSS » Thu Sep 13, 2012 5:07 pm

whats it mounted with?

User avatar
Dion.Rentos
Posts: 2096
Joined: Sun Aug 26, 2012 1:41 pm
Location: Palm Bay Florida
Contact:

Re: Back under the Camaro again :-(

Post by Dion.Rentos » Thu Sep 13, 2012 5:12 pm

AntiPriuSS wrote:whats it mounted with?
It had Plastic Clips holding it. I was able to remove them and mount it up another inch with something else i had. should be OK now!

User avatar
AntiPriuSS
Posts: 198
Joined: Mon Aug 27, 2012 4:27 pm
Location: Satellite Beach

Re: Back under the Camaro again :-(

Post by AntiPriuSS » Thu Sep 13, 2012 5:23 pm

ZIP ties and duck tape to the rescue!

User avatar
1JEWLDSSRS
Posts: 608
Joined: Wed Aug 29, 2012 10:24 am

Re: Back under the Camaro again :-(

Post by 1JEWLDSSRS » Thu Sep 20, 2012 6:52 pm

Noman, it's a Camaro,, need some Nascar 200MPH tape..Lol.. :dance: :dance: :dance:

Post Reply